*

Juniper FireFlyでJUNOSと仲良し

ネットワークG 南部です。

普段からネットワークに触れていることを楽しんでいるのですが、最近のお気に入り、Juniper社の仮想ルータ、FireFlyを使って検証環境を作ってみたいと思います。

ダウンロード

 

インストール環境

インストール環境は、たまたま手元にあった24GBメモリの積んであるサーバにVMware ESXi5.1(無償版)をインストールしたものです。

最終構成

ESXiのなかに4つのインスタンスをつくり、以下のような構成をめざします。

ubuntu1(11.0.0.10)からubuntu2(22.0.0.10)にpingが届けば目標達成とします。

kousei

 

IPアドレスは適当に采番しましたが、インターネットに出ることは想定していないので突っ込まないでください。

 

 

Fireflyのインストール

- “ファイル”-”OVFテンプレートのデプロイ”から、拡張しovaのファイルを選択して”次へ”を押していくとインストールできます
- そのままだとFireflyのインタフェースが2個で寂しいので、5個に増やします


            ↓
WS000002

- 電源をいれると数分で起動します
- コンソールを開くとログインIDを聞かれています
- ログインIDはroot
- 「cli」と打つことでJUNOSのシェルに移るので以下を打ちます
- 「configure」と打つことでコンフィグレーションモードに移行します

 

set system root-authentication plain-text-password
 <パスワードを2回>
 delete security
 set security forwarding-options family inet6 mode packet-based
 set security forwarding-options family mpls mode packet-based
 set system login user lab class super-user
 set system login user lab authentication plain-text-password
 <パスワードを2回>
 set system services telnet
 set interfaces ge-0/0/0 unit 0 family inet address 192.168.233.11/24

とりあえず、ココまでコンソールでがんばって打ってください。

さてコミット(設定の反映)です

commit

これで設定が反映されました。しかしながらパケット転送モードの変更は再起動しないと反映しません。

lab@firefly-1# run request system reboot
Reboot the system ? [yes,no] (no) yes

再起動後はtelnetで作業ができます。

ネットワークの設定

ESXiからはネットワークの設定をしてあげます。
(GUIからだと面倒ですね・・・)

WS000003

WS000004

WS000005

WS000006

インスタンスのネットワークに上記で作ったネットワークを割り当てます。

WS000008

同じように、Fireflyをもう一台構築してください。

WS000009

Fireflyへのログイン

やっと2台Fireflyがつながりました。あとはルータの設定をモリモリするだけです。

2台のFireflyにログインします。puttyなりteratermなり好きなのを使ってください。

私はlinuxの端末からログインします。

firefly1へログインする・・・telnet 192.168.233.11

firefly2へログインする・・・telnet 192.168.233.12

ログインできましたでしょうか?

[lab@localhost ~]$ telnet 192.168.233.11
Trying 192.168.233.11...
Connected to 192.168.233.11.
Escape character is '^]'.
(ttyp0)
login: lab
Password:パスワード
--- JUNOS 12.1X46-D10 built 2013-12-05 15:04:51 UTC
lab>

Fireflyの設定

設定の時はコンフィグレーションモードに移行します。

lab> configure
Entering configuration mode
[edit]
lab#

ホスト名を設定します。

lab# set system host-name firefly1
[edit]
lab# show | compare
[edit system]
+ host-name firefly1;
[edit]
lab# commit
commit complete
[edit]
lab@firefly1#

簡単に説明します。

JUNOSでは設定はすべてsetで始まるコマンドを打ちます。

ホスト名であれば、set system host-name ~~ です。

show | compare は今追加した設定部分だけを抜き出して表示してくれます。

commitは設定変更です。

忘れずに。CiscoからJUNOSに移るとcommitを忘れることがありますが、そのうち慣れます。

 

firefly1側の設定を入れます。

set interfaces ge-0/0/1 unit 0 family inet address 11.0.0.1/24
set interfaces ge-0/0/2 unit 0 family inet address 1.0.12.11/24
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0 passive
set protocols ospf area 0.0.0.0 interface ge-0/0/2.0

commit

 

firefly2側の設定を入れます。

set system host-name firefly2
set interfaces ge-0/0/1 unit 0 family inet address 22.0.0.1/24
set interfaces ge-0/0/2 unit 0 family inet address 1.0.12.12/24
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0 passive
set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
commit

 

firefly1とfirefly2でOSPFが正常にはれているのを確認します。

lab@firefly1# run show ospf neighbor
Address Interface State ID Pri Dead
1.0.12.12 ge-0/0/2.0 Full 1.0.12.12 128 38
[edit]
lab@firefly1#
ちゃんとfullになっています。

ubuntuの準備

ネットワークの話を書いているので、サーバのインストールに関する部分は省略します。

ただし、それぞれのサーバにスタティックルートを書く必要があります。
- ubuntu1の設定

ifconfig eth1 11.0.0.10 netmask 255.255.255.0 up
ip route add 22.0.0.0/24 via 11.0.0.1

- ubuntu2の設定

ifconfig eth1 22.0.0.10 netmask 255.255.255.0 up
ip route add 11.0.0.0/24 via 22.0.0.1

 

 結果は?

root@ubuntu1:/home/lab# ping 22.0.0.10
PING 22.0.0.10 (22.0.0.10) 56(84) bytes of data.
64 bytes from 22.0.0.10: icmp_seq=1 ttl=62 time=16.4 ms
64 bytes from 22.0.0.10: icmp_seq=2 ttl=62 time=19.2 ms
^C
--- 22.0.0.10 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 16.431/17.846/19.262/1.421 ms
成功でした。

 

関連記事

cloud-mon

改善していける監視を目指して 第一回

ネットワークG 平(ひら)です。 Bit-isle promptに記事を寄稿するにあたり、新し

記事を読む

cloud-mon

改善していける監視を目指して 第二回

ネットワークG 平(ひら)です。 第一回では、主にクラウドサービスの状態監視(イベント監視)に

記事を読む

構成図

Softlayer Direct Link を smokeping で測ってみた ~その2 インスタンスの作成~

こんにちは。 ネットワークGの藤岡です。 前回に引き続き Softlayer についての記事

記事を読む

no image

誤解しがちなVMware等のHyper VisorのHAの期待効果

VMware 等の Hyper Visor の HA 冗長構成では MTBFを改善できない。

記事を読む

techops

システム運用サービスで必要なこと

こんにちは。ビットアイルの 大野 です。 本日は ITシステムにおける一連のライフサイクルの中

記事を読む

構成図

Softlayer Direct Link を smokeping で測ってみた ~その1 構成~

こんにちは。 ネットワークGの藤岡です。 昨年 IBM が Softlayer を買収したニ

記事を読む

awssummt

新入社員がAWSサミットに参加してきました。

こんばんは、最近配属が決まったばかりのビットアイル新入社員です。 先週7/17、18に品川で開

記事を読む

ispっぽく

Juniper FireFlyでJUNOSと仲良し その2

ネットワークG 南部です。 前回は2台のubuntu間でpingが届くところまで確認しましたが

記事を読む

no image

ビットアイル・エクイニクスのエンジニアブログです。データセンターの最前線から様々な情報をお伝え致します。

構成図
Softlayer Direct Link を smokeping で測ってみた ~その2 インスタンスの作成~

こんにちは。 ネットワークGの藤岡です。 前回に引き続き So

構成図
Softlayer Direct Link を smokeping で測ってみた ~その1 構成~

こんにちは。 ネットワークGの藤岡です。 昨年 IBM が S

cloud-mon
改善していける監視を目指して 第二回

ネットワークG 平(ひら)です。 第一回では、主にクラウドサービ

cloud-mon
改善していける監視を目指して 第一回

ネットワークG 平(ひら)です。 Bit-isle prompt

ispっぽく
Juniper FireFlyでJUNOSと仲良し その2

ネットワークG 南部です。 前回は2台のubuntu間でping

→もっと見る

PAGE TOP ↑